Radzen won't open on MAC after last update

Hello;

After the last update, my Radzen no longer opens on my MacBook. I tried to reinstall and the problem persists. I believe the update is corrupted somewhere.

Where does Radzen save updates on the Mac? I believe that by deleting it manually the problem is solved

1 Like

Hi @raphaelz,

Thank you for reporting this. We are investigating how to fix that.

Thanks; Here is the error log:

radzen-error.zip (25.8 KB)

I have uploaded a build for you to try here. We tested it on a couple of Macs but would appreciate if you give it a try as well.

Thanks!

I uninstalled the current version and installed this one, and it still won't open ... :frowning:

What is the version number that you installed?

At that moment, I tested the version you uploaded

I am asking because we tested that version on three different macs and it was working ok. It's version is 2.43.1. The current official version (2.43.0) indeed fails to start (confirmed on all three test macs).

that's right ... As I realized, as soon as I received version 2.43.0 the system stopped. Before that, it worked. I always update Radzen as soon as I see the update alert.

I'm having a similar issue, although I was running Radzen 2.42.9 in Parallels using a iMac running Windows 10. This morning I got an alert that a newer version was available so I installed it and after the install it opened and immediately closed. I restarted (the Windows OS) and tried to open it and it closed right away. So I uninstalled it completely, then downloaded the latest version (2.43.1) and installed it and same thing happened.

Right now I can't use the designer too. Like the others, it closes after a few seconds. I'm on windows 10.
This really scares me. I'm about to close my first contract on a client to use Radzen. I wonder if I really should... This is very serious.

@pbotas You have the same issue as original post however on Windows? We had problem with installer after Electron upgrade however the issue was only on Mac and it was fixed already. The latest version works normally on every machine both Windows and Mac we have.

Yes. However, I managed to uncheck the "Check for Updates" menu before Radzen closed again, I don't know if it's related in any way. After a couple of times opening Radzen, it seems to be fine now. I't open for 3 minutes or so now.

The original issue described in this thread was about Radzen being unable to start on a Mac. This issue sounds different - if Radzen closes after a while then there might be indeed a problem with the autoupdate which we cannot reproduce. Can you attach the Radzen log file?

We upgraded Electron in 2.43.0 which required upgrading a lot of other dependencies (the autoupdate being one of those). We've spend the last week fixing regressions caused by this but there could be more that we have missed.

Sure:
log.zip (13.2 KB)

I did one more experiment here:

  • I completely uninstalled Radzen;
  • I installed version 2.40.0 that I found in my downloads folder;
  • It ran normal until now (2.40.0)
  • I waited for the system to update. I received version 2.43.1 and it opened without problems.
  • I ran a project to make sure everything was working. The project ran smoothly;
  • I closed Radzen and opened it again. It performed without problems;

I confirm this issue. Radzen 2.43.0 for Windows will fail to download the 2.43.1 update because of this issue: https://github.com/electron/electron/issues/21566

Long story short if you have Radzen 2.43.0 it will fail to start now that we shipped 2.43.1 :frowning: The solution is to manually download latest Radzen from our web site.

P.S. Upgrading Electron was never a pleasant experience. This time it is far worse though. Hope the security updates and performance improvements are worth it.

1 Like

Thank you @korchev, your team efforts bring the needed confidence.

i downloaded new version and still does not open on Mac Catalina