Could not find 'Radzen.createDatePicker'


I have a really weird issue with the latest version 4.28.4 also 4.28.3. One of my blazor page is giving me the error below (all other pages are fine). All other pages are OK and it working on my PC (windows). Got the issue only my docker images running on linux. Reverting to 4.27.01 is fixing my issue. Iam doing almost daily update since a year and never got this error... I tryed a different browser with the same issue. Radzen.Blazor.js is loaded

[2024-03-21T13:15:49.455Z] Error: Microsoft.JSInterop.JSException: Could not find 'Radzen.createDatePicker' ('createDatePicker' was undefined).
Error: Could not find 'Radzen.createDatePicker' ('createDatePicker' was undefined).
at Array.forEach ()
at l.findFunction (
at _ (
at new Promise ()
at y.beginInvokeJSFromDotNet (
at Xt._invokeClientMethod (
at Xt._processIncomingData (
at Xt.connection.onreceive (
at Microsoft.JSInterop.JSRuntime.InvokeAsync[TValue](Int64 targetInstanceId, String identifier, Object args)
at Microsoft.JSInterop.JSRuntimeExtensions.InvokeVoidAsync(IJSRuntime jsRuntime, String identifier, Object args)
at Radzen.Blazor.RadzenDatePicker`1.OnAfterRenderAsync(Boolean firstRender)
at Microsoft.AspNetCore.Components.RenderTree.Renderer.GetErrorHandledTask(Task taskToHandle, ComponentState owningComponentState)
log @ blazor.server.js:1

my application threw a similar error.

A security update from Microsoft updated the framework from 7.0.16 to 7.0.17 and I received an error message from VS 2022.

I then updated all components in the project and then the error occurred (the filter on the datagrid automatically loads the DatePicker).

The problem was solved for me by updating the hosting package on the server (Windows with IIS) and explicitly deleting the browser cache!

Maybe it will help you too.

Good luck.

Hi I put < script src="_content/Radzen.Blazor/Radzen.Blazor.js?v=@(typeof(Radzen.Colors).Assembly.GetName().Version)">< /script>

and moved to the last js and it fixed.


Had the same error after an update recently. Clearing my browser cache resolved the issue.

It works! Thank you!

Having this same issue, but only on our servers and not locally. This script appears to have fixed it, but I think the underlying issue causing it needs to be addressed.

The underlying issue is cached (old) Radzen.Blazor.js file. This is solved by appending the assembly version in the query string. This way after every upgrade the URL will change thus invalidate any cached versions.

Does anyone know an easy way to do this for Blazor WASM and index.html? I've been searching this for a long time but so far I just manually append a DateTime.Now.Ticks when I find similar issues.

Hey Sofiageo, for Blazor WASM you can't run a dynamically generated version for the script include tag as it's being set in the index.html file. (Not dynamically generated by Blazor)

The simplest way to handle this is every time you update the Nuget package you manually increment the version in the HTML file i.e.

 <script src="_content/Radzen.Blazor/Radzen.Blazor.js?v=4.29.1"></script>

You could probably handle this nicer in a CI-CD to replace the value with that from the Nuget package reference.

I just had the same problem and a simple ctrl+F5 fixed it it seems.