since yesterday, the building of the package seems to be wrong. It always creates a package with an older content. In the meanwhile, I added new pages and used another theme. It is very strange. Is there something that I can reset?

Thanks in advance, Markus

Hi @YnotBetter,

Check if the Angular compilation passes - for deploy it's build in production mode and you might have some compilation errors.

I had no compilation errors. The zip file has always been created. I also could run the application locally.

I tried to delete the client folder as it helped me in the past: Cannot find module 'rxjs-compat/BehaviorSubject' - #4 by korchev

Now, I got compiler errors, which I haven't before. (couldn't find material.css in the assets)

Starting the deployment once more, seems to fix it. I will post if this solved the issue...

It is still some kind strange. It seems, it is now the latest version that is in But now I have only the "de"-folder for my German culture in the wwwroot-folder in Before, I had much more content in it.
Do you have any ideas @enchev ?

Thanks, Markus

Unfortunately I’m not sure what can cause this.

Im my application folder, /client/dist/ is also empty (besides the "de"-folder). There should be more content as well. Any ideas why the files in this folder are not created?

Is there a way to enforce that? Running the application out of Radzen works...

Here is what I have after Deploy to ZIP of an Angular .NET 6 app with CRUD pages from our sample database with two cultures:

In my opinion your Angular app cannot be compiled in production.

Hmmm...ok. But where can be the difference that causes a compilation error. I couldn't find anything in the log files as well

Now I got a build error. It seems I have a general issue with the angular package...

I fixed it. At the end, deleting of the client folder was the answer all the time. :man_facepalming: