The Method Designer locates/continues the wrong place after adding a variable

Hi team,

I hope I'm not boring you with my reports. I try to make time regularly to test RBS.

When I tried the following scenario I faced an issue.

Scenario: Realizing that the required variable (isSomethingTrue in this sample) is not defined while writing an if block.

The following video shows what happens.

An additional question: When I tried to test this scenario I saw that I could not create a function from the Method Designer. The only way is to write the definition to the code manually.
After some digging, I found the following topic, on the forum.

This is a very useful method if you working on a page with objects. However, I think an independent create functionality is necessary for the Method Designer. Will you plan this functionality in the future?

We will fix that in the next release.

No, not in the immediate future. You can just type in the new method name :slight_smile:

1 Like

It seems ok after 1.20.8