RadzenMask problems when writing an IP address

Hello Radzen Team!

My clients have been experiencing some issues when using this mask for an IP address:

The biggest complaint is that they can't insert IPs such as, that don't have three-digit sets, because the mask property requires an input. To circumvent that, I added the space character to the pattern. This worked for a while, but now again I'm in need of a better solution.

The problem now is that the IPs are stored in the database like "192.168. 0.123", " 0 . 12.345. 6 " etc. and errors occur when trying to update these values from other APIs.

The ideal situation would be that if in a mask such as the IP mask, if I insert the dot character, it would end the current sub and jump to the next one.

Any ideas?

Hi @kim,

In this case instead value binding you can use Change event to remove the whitespaces and set the property value manually.

1 Like

Worked like a charm, thanks for the idea!

Actually not so charming.

There was a problem when updating the mask value after using your suggestion:

Which I fixed by moving the replace to the submit event:

Then by adding the spaces in the Load event:

Now everything works as it should:

1 Like

The problem with expression in your other thread is fixed in the just released update.

1 Like