Problem when Deplying i Azure


I have developed an app that runs fine on local maskin! :blush:

I have created a SQL Server om Azure (SailitV2SP) and a Database and also an APP in App-service. I can ping the SQL server from the APP server, but when I run the app seams to not have any connection to sql server.

So, I build a new app
The app does not work. It calls a stored procedure.

So I build a another new one app that has 3 pages, a landing page, a page with call to a stored procedure and a call to a table

This one work, both call to Stored Procedure and select from table.

The Apps uses the same SQL database. I have compared the Json script from both App services, they are the same.

I didn’t get the deployment from radzen UI to work so I used Visual Studio

So what are I'm doing wrong, connection strings.....??

There is an exception displayed in the browser development tools - login failed for user XXXX. You have to check the connection string and whether the Azure instance has access to the SQL server.


Solved after help from Azur support. When I deployed from Visual Studio the connectstring was wron and this a fixed in the Azur portal