Problem in Blazor DataGrid with Custom Classes

Just for fun I am trying to move a project from Angular to Blazor to see some of the advantages.
I am running into an issue though.
I have a class called "Character" for an RPG system. That class is on the namespace "BlazorProject" as such I call it using "BlazorProject.Character".
I call the function GetCharacters on Radzen which is pretty simple:

public IEnumerable<BlazorProject.Character> GetCharacters(){
MongoClient client = new MongoClient(connectionString);
var database = client.GetDatabase("RPGBot");
return database.GetCollection<BlazorProject.Character>("Characters").AsQueryable().ToList();

I call the function on the Invoke Method function on Load.
Up to here it builds just fine.
When I put a datagrid though to be able to see these values on the page... I get an error.
On the designer page the datagrid gets generated like this:
protected RadzenGrid<BlazorProject.Models.Character.Character> grid0;
Which is... clearly completely wrong.
Why does this happen? Am I doing something very wrong?

We fixed a similar issue with today's release 2.44.9. Try upgrading it (you have to manually download it though). Then add the DataGrid again and set its Data property. The type should be correct this time.

Sadly I did update just before filing this error, in fact I tried to do this again today exactly because I saw that patch. I will try again in a few hours.

See on the result page for the command:

Completely right

Seems right.
Version of Radzen:

Same error happens with DataList
Making a Label and puttin it's text component to ${Variable1.ToArray()[0].Name} Works though.
If I add them to the code generation ignore list and remove the bogus class names it does work. Kinda.

Try adding a custom attribute TItem to the DataGrid with the correct class name. It should override the autodetected one. We will investigate a possible fix.

Going to the Meta file and changing it there on the itemType field was a fix for that.

Going to bump this as I updated to the newest version that came out yesterday and this issue remains

The issue remains here even after changing to 2.44.11

Unfortunately we can't reproduce it after the latest fix. You can try recreating the DataGrid or setting TItem as an attribute.