Button MouseEnter not working when changing Visible State

When toggling the state of the Visible Property on a Radzen button, the MouseEnter call never gets triggered. I also tried without toggling the disabled property, same behavior. If I set the Visible property to "true" it works fine.

<RadzenButton Click="@Remove" Text="Permanently Ignore" Style="margin-top: 20px;" Visible="!disableIgnoreButton" Disabled="disableIgnoreButton" MouseEnter="@(args => ShowTooltip(args, new TooltipOptions(){ Duration = 4000, Text="Remove the item from this list permanently", Position = TooltipPosition.Right }))">

Not sure if this is the intended behavior or if there is another way to accomplish this.

Hi @codep,

What’s your Radzen.Blazor version? Are you using the latest?

I was using 2.15.16. Before replying I updated to 2.15.18, though still the same results.
Thanks!

Hello @enchev, I'm also running into a similar issue, but when used with a RadzenIcon within a RadzenGridColumn of a RadzenGrid.

Here is my code:

 <RadzenIcon Icon="info" Style="vertical-align: middle" Visible="IsVisible"
                                                        MouseEnter="@(args => ShowTooltip(args, new TooltipOptions(){
                                                                          Position = TooltipPosition.Right,
                                                                          Style = "color:#000; font-size:90%",
                                                                          Text = string.Join(", ", @data.Name, @data.Team),
                                                                          Duration = 5000 }))">
 </RadzenIcon>

The issue is that the MouseEnter event does not fire consistently, i.e., the Tooltip is displayed only for some rows in the Datagrid but not others. However, as @codep mentioned, it works fine when the Visible property is set to "true". Any idea why this is so?

I also tried upgrading to the latest version 2.16.3 that was released about 22 hours ago, but still see the issue. Appreciate any insights or workarounds that you may have. Thanks!

@enchev Posted this query as a separate question here: MouseEnter event does not always fire

@codep Have you been able to fix this somehow?

I ended up wrapping the control in an IF statement to control visibility instead of the visible property on the control. This worked fine in regards to the tooltip showing.

@codep Yes, I guess that's all we can do for now. Thanks for sharing.