UI Binding Issues via IReadOnlyRadzenDictionary<> Issues

I have built a trading screen.
The application is working.
Part of the UI is inside a template.
When I look at the child UI from the parent, the does not appear to be anything wrong.
However, when I edit the child UI via the template it is saying "IReadOnlyRadzenDictionary<> could not be found. (are you missing an assembly?)" See screenshots.

Hi @cedric_harris,

Please zip and send us your application meta folder at info@radzen.com.

I have emailed you the requested .zip file.

Hi @cedric_harris,

Unfortunately I was not able to reproduce this error:

Will the error go away if you close and open Radzen again?

I have closed the project in Radzen and reopened the project and I still get the error.
The error is occurring within the dropdownGrid when I use an Image to display its image based on the path of the url property.

Could we do a video meeting so you can see what is occurring in my environment?

Apparently Radzen is not able to handle collections.
When I use either Pairs = new List<CoinAPI.REST.V1.Icon>{}
or Pairs = new CoinAPI.REST.V1.Icon[]{}

The result is the error I reported. The application will run but Radzen thinks it is missing an assembly on my machine and environment that you have on your machine.

There is a collection/dictionary assembly that Radzen is looking for that is missing on my machine.
Do you have any clues on this dictionary or collection?

There is no additional assembly that is missing at your side. This is just Radzen designer failing to render the component in this particular case - as you've noted everything works normally runtime.

Can you zip and send us full app including server folder with additional reference at info@radzen.com? If the zip is too big you can use file sharing service like Google Drive, One Drive, etc.

Btw we are close to RC release of Radzen Blazor Studio where such complex scenarios like yours are handled much better:

Also, I have noticed that this behavior only occurs when inside a template that is being edited.

I see there are previous reports for the same error however we were unable to replicate it so far:

UPDATE: I was able to replicate it! It is related to component with template inside RadzenSplitter!

We will do our best to provide fix later this week!

I thought it was weird that it only happened deep in the edit pane.

Also, might I make one more suggestion in regards to the login template.
Currently, Radzen only supports one UI/layout for the login.

There should be two (2) layout options for the login. One based on the default and one based on a sideview like the following:

Most applications allow users to login via a side/split screen.
I believe this will go a long way to allowing users to build more progressive looking UI with this option as a login screen.

I look forward to your update later this week.

Many thanks for your attention.

The latest build fixed the issue. Please see the latest screenshot.
Many many thanks.

There appears to be a similar issue with using databinding for the iconstyles.
I am using databinding to set the icon style so that I can change the color of the icon dynamically. (see the screenshot)
The code I have is working. However, the IDE is giving the following message that makes it uneditable.

Thanks @cedric_harris! We will check it immediately!