treeGrid component does not expand on first try

I had problems implementing the treeGrid component.
So I created a new project and followed the instructions on
to realize even with the demosetup the grid is bugged.

When you click on the little arrow to expand a data-entry it will not load additional lines.
Click it again to 'close' ... uhm ... nothing. Click it again and see the sub-entries getting rendered fine.

This issue happens for every line separately, no errors in the console.

Does the online demo work for you? We couldn't find the reported issue there.

Yes the online demo works, but only in Chrome.

Which browser and version are you using?

latest Firefox release (67.0.2), tried to disable all blocking features and an adblocker, does not make a difference

This is strange. Just tested with latest FireFox and still nothing. Here is what I tried - are you doing something different?

I strangly cannot reproduce the issue anymore, loading a new line takes just a sec longer than in your gif but it still loads reliable nonetheless. I will try to record the behaviour the nexts days if I see it happen again.

Here you go, got that nasty bugger on cam, even in Chrome :smiley:
I've put a console.log into that data method so I can be sure it is reading stuff from the database.

This seems to be your application though and not the online demo. We need to reproduce the issue locally somehow in order to troubleshoot.

Ok, I will try again until I can do a vid on the online demo, I could have sworn it was the same there, but unfortunately it's not easily reproduceable.

Can you reproduce it with this sample app I did? (3.0 KB)

Oh wow, now it get's strange:

  • that sample is basically what is listed at
  • I have the exact same problem as shown in the gif I posted earlier in this thread
  • I can reproduce this issue in a current chrome and a current firefox version (on multiple machines, even on multiple networks)
  • The issue vanishes if the website is left open for ... uhm ... let's say a minute

When I click the first time, I can see in the console that there is a request being sent and an positive response is arriving, but the component doesn't render, if I send the request a second time (through clicking the expand-arrow twice) the arriving data is instantly rendered.

Something in the client-side code takes ages to render if the request is done the first time for one specific data-entry. I can refresh the page through pressing F5 instantly and reproduce the same behaviour again.

Debugging it gets me - sadly - nowhere. The event which gets fired from opening a row lands in the zone.js and that's stuff which I can not interpret anymore.

Edit: I have to retract that statement about stuff starts to render fine a minute later, it's worse, a minute without interaction later the grid starts to render stuff on expanding notes, but it doesn't look right too. Sometimes I click a row and one row below my click starts to expand.

Did I mention that the online demo has none of these problems? It just works :frowning:

Hi @Moo,

I was able to reproduce the problem with your app - once I have more info I'll post it here.

Best Regards,

Hi @Moo,

The issue was fixed immediately and we will release a hotfix.

Best Regards,

1 Like