The tool doesn't retrieve data from views


#1

Seems like something is wrong with views at least in Postgres - they look very different from the original data in the DB: the tool grabs only first row for each id (which is not unique - the view is a compilation from many-to-many tables) and substitute the rest by its values. Then grabs the first row for the next id and does the same…

The problem can be solved by creation of the index on the view, but anyway it should not be like that.


MSSQL Crud tables duplicates data
#2

It is a known problem with EF:

Radzen will mark first non-nullable field as key however there are cases (first non-nullable is not unique for example) when EF still will return duplicate records. You can provide additional configuration using data-context partial class. For example:

public partial class NorthwindContext
{
    partial void OnModelBuilding(ModelBuilder builder)
    {
        builder.Entity<DataContextAdditionalConfiguration.Models.Northwind.OrderDetailsExtended>().HasKey(table => new
        {
            table.OrderID,
            table.ProductID
        });
    }
}

Sample app can be found here:


#3

No to start a new topic: seems like there is still a problem with views. EF creates data model for views with random keys. One can see it both in data.json file and in the corresponding .cs file in Models folder. It leads to undesired behaviour, e.g. the field can be empty in the view, but EF returns an error as it expects this field being not NULL.
I could not find the way to explicitely assign keys, even after creation of id field and recreation of the data model the key is still the same wrong. What can I do?