TextBox not working in dialog

When used in a component shown with RadzenDialog, a Radzen textbox accepts no input. I am using 4.25.7.
This used to work in 4.13.0

We have the same problem in our solution. We have tried what @enchev Vladimir suggested on a blank page, exactly as shown and it is not working.
We even tried downgrading NuGet package to 4.13.0 and it is not working.


Hi @miland,

We've just fixed something that might be related to your issue. Try Radzen.Blazor 4.25.11.

Hi Vladimir @enchev

I have just solved it on my side.
two things i have done

  • Moved <RadzenDialog /> definition to MainLayout
  • removed these 2 lines from the appSettings (i have added this few days ago)
"Microsoft.AspNetCore.SignalR": "Debug",
"Microsoft.AspNetCore.Http.Connections": "Debug"

I am not sure how the appSettings debug lines would affect but that solved it

Thanks for your help.

Most probably this solved your issue, other stuff are definitely not related.

I agree with you, but i have tried with first moving Dialog to MainLayout and it did not work until i removed the other thing from appSettings.

I wanted to post both things as it might save somebody hair polling morning. :smiley:
Thank you