SSRSViewer: uncaught error.... cannot match any routes


after updating to 2.10.1 I get error "uncaught error.... cannot match any routes" when I run my app in developer mode and try to open a report in SSRSView

The report server is running under the URL localhost/ReportServer .....I can manage report server, access and open reports using this URL when I use a browser...

Error in Chrome:

Error in Firefox:

My environment:
Radzen 2.10.1
SQL Server 2017 + SSRS
Windows 2012R2

Hi @Heinz,

Please clear the PWA storage data for this site as shown here:

In addition try checking if there is a client\node_modules directory within your app. If there is - delete it.

Indeed I do have a client\node_modules directory.
And I have deleted it... but when I "run" the app,the client\node_modules directory is re-created (as a link)


I also have cleared PWA cache, but still I see the error

In Radzen development environment everything seems to be OK, I even have a preview of the report inside the SSRS control:

But when I run the app and try to open the report it I see this "cannot match any route error" :

(Chrome Browser)

Can you attach this page json file (from meta folder)?

I hope this is the correct file, taken from ...\Radzen\App2\meta\reporting.json

  "access": [
  "components": [
      "components": [
          "name": "pageTitle",
          "size": "H1",
          "text": "Reporting",
          "type": "heading"
          "name": "ssrsviewer1",
          "reportName": "Test0",
          "reportServer": "http:/localhost/ReportServer/",
          "style": {
            "height": "268px"
          "type": "ssrsviewer"
      "container": "main",
      "type": "content"
  "layout": "Main",
  "name": "Reporting"

When I was having this issue, the initial load would generate the route error. I could then clear the data under the application tab, then when I clicked refresh the page would load and generate the report correctly 1 time. Is it doing the same for you? When I click refresh after that successful load it would give me the route error again.

I've just made exactly the same setup however everything is working as expected on my end:

Not sure what's going on honestly.

I have the same issue, had no luck with the solutions given.

Feedback : I solved my issue by using http://localhost/reportserver instead of localhost/reportserver in the "ReportServer" property of SSRSViewer

I think your problem comes from this :

http:// :slight_smile: