SSRS error "refused to connect"


#1

Hello,

I am new to Reporting with SSRS... I have created a testreport and I can open this report in my browser (without asking for username / password):

display_in_browser

But if I add a SSRSView to my Raden page and run the app I get an error “refused to connect”:

Here are my settings for the SSRSView:

ReportServer: http://localhost/Reports_SQLEXPRESS/
ReportName: report/Test1

Environment is Windows2012 R2 and SQL2016 Express.

What could be the problem?


#2

Try setting ReportName to Test1 instead of report/Testi1.


#3

I have changed ReportNameto "Test1", but I get same error.
And in Radzen I see "Type Error":


#4

Hi @Heinz,

What is your Radzen version? Are you using latest 2.9.4? In one of your screenshots I've noticed an empty parameter (no name and value) - please remove it.

Best Regards,
Vladimir


#5

Hallo,

I have removed the empty properties,and I have tried some more things:
-I have changed Port for the Reporting Server from 80 to 88
-I have used IPNr of Reporting Server instead of its name
-I have disabled firewall

Still I see the same error in Chrome: "Refused to connect"

And Chrome Console says this:
Refused to display 'http://1.2.3.4:88/Reports_SQLEXPRESS//Pages/ReportViewer.aspx?%2Freport/Test3&rs:Command=Render&rs:Embed=true'
in a frame because it set 'X-Frame-Options' to 'sameorigin'.

Firefox similar:
Load denied by X-Frame-Options: http://1.2.3.4:88/Reports_SQLEXPRESS//Pages/ReportViewer.aspx?%2Freport/Test3&rs:Command=Render&rs:Embed=true
does not permit cross-origin framing.

Internet Explorer:
This content cannot be displayed in a frame

So this messages says something about iframe and X-Frame-Options....
So I have tried to change the response header in ISS (I have tested some X-Frame-Options ), but it did not help.
And I think that SSRS does not use IIS anyway but has other mechanism... I have read somewhere that current version of SSRS does not use IIS anymore... so I wonder where I could the set response header...

While searching in Google I have found some recommendations to use parameter "rs:Embed=true" in URL call to the report, and as I can see in the console message this parameter is used... but doesnt help...

So in the beginning I thought this was somehow a problem with credentials / permissions.... but now it seems it is a problem related to the usage of iframe.... ?

Here my environment:
Windows2012R2
SQL 2016 Express Advanced (+ Reporting Services)
Radzen 2.9.4


#6

Hi @Heinz,

Please use localhost instead IP for both Angular application (Radzen will run the app at http://localhost:8000/) and Report url (http://localhost/Reports_SQLEXPRESS/).

If your report server is not running on localhost please enable useProxy for the SSRSViewer.


#7

OK, now it works - thank you :slight_smile: