Run/Debug app from Visual Studio 2017

When I run the application in VS 2017 get this window to appear then all seems to hang. I would like to run the app from VS2017 and would like to know if I can debug in it as well.

When you start the application from Visual Studio all needed dependencies will be installed in client/node_modules which takes time. You can monitor Visual Studio output window for progress, more info can be found here:

I have waited some period of time as the documentation had suggested. However, nothing happens. Here is the status after an hour of waiting. (see image). The output window does not indicate anything being installed.

Any suggestions. Thanks

I am just curious if these components are needed why are they not part of the project file created by Radzen?

I have tried any number of ways
to install them and have had no success. I have tried command line, and Visual Code in addition to VS.

The app loads and runs from the Radzen ide. Probably operator error but I am clueless about getting this debug environment working.

Suggestions are appreciated.

I am just curious if these components are needed why are they not part of the project file created by Radzen?

They are part of the project file created by Radzen - there is code that installs them in the csproj/vbproj file. There is probably some error though which should be visible in Visual Studio's Output window. Your screenshot shows the Debug - check what the other logs have by selecting the other options from the Show output from dropdown.

This is a Server side - Core - VB app. Could it not like VB?

Checking those other logs. Build and Build Order show this message
"========== Build: 0 succeeded, 0 failed, 1 up-to-date, 0 skipped =========="

The error list gives this warning message ( not an error)

"Warning NETSDK1059 The tool 'Microsoft.EntityFrameworkCore.Tools.DotNet' is now included in the .NET Core SDK. Information on resolving this warning is available at ( project C:\Program Files\dotnet\sdk\2.2.100\Sdks\Microsoft.NET.Sdk\targets\Microsoft.NET.ObsoleteReferences.targets 33 "

So far as I know, I have updated all Core SDK components on my system so this is a mystery.

Are you running the project in Debug mode? Also can you paste the contents of the vproj file just be sure it it up to date.

I am running in Debug mode. I have tried both just to see if that was an issue. Same result. This could easily be operator error but I have not found the issue.

Here is the file contents you asked to see.

Any ideas or suggestions are appreciated.

John W.

<Project Sdk="Microsoft.NET.Sdk">
<PackageReference Include="Microsoft.AspNetCore.All" Version="2.0.0" />
<PackageReference Include="Microsoft.EntityFrameworkCore.Tools" Version="2.2.0" PrivateAssets="All" />
<PackageReference Include="Microsoft.VisualStudio.Web.CodeGeneration.Design" Version="2.0.0" PrivateAssets="All" />
<PackageReference Include="Microsoft.AspNetCore.OData" Version="7.0.0" />
<PackageReference Include="Microsoft.AspNetCore.SpaServices.Extensions" Version="2.0.0" />
<PackageReference Include="DocumentFormat.OpenXml" Version="2.8.1" />
<PackageReference Include="Microsoft.IdentityModel.Tokens" Version="5.2.1" />
<PackageReference Include="System.IdentityModel.Tokens.Jwt" Version="5.2.1" />
<DotNetCliToolReference Include="Microsoft.EntityFrameworkCore.Tools.DotNet" Version="2.0.0" />
<DotNetCliToolReference Include="Microsoft.VisualStudio.Web.CodeGeneration.Tools" Version="2.0.0" />

The vproj doesn't have the required code. Can you try deleting it? Radzen will recreate it on next run. You could also get an error that view Index cannot be found - please ignore it for now. The application should open a new browser window on port 8000.

I did that an more code was generated in the project file. I tried to run from VS2017 and it still hangs as before. No errors, not output messages etc. I do notice that it is listening on Port 5000 not 8000. The Radzen setting show the Port at 8000. However when I run in Radzen it also shows listening at Port 5000. So it is not seeing the setting.

I manually changed the setting in the code to listen to Port 8000. It then reports an error that it cannot open to files npm….. and npm..

When I change it back to Port 5000 these errors disappear.

This is from the vb code file as you can see it codes it as Port 5000

Function BuildWebHost(args As String()) As IWebHost
Return WebHost.CreateDefaultBuilder(args) _
.UseKestrel() _
.UseUrls("http://localhost:5000") _
.UseStartup(Of Startup)() _
End Function

I would be happy to start a clean project if there is some way for me to move a page to the new project. I have a fair amount of time in building a layout. I would not like to lose that work.

I created a test app. I selected server side, Core v2.x, and VB. If you will notice there are two port numbers 8000 under the theme and Server Port 5000. When I run the app it listens to port 5000. Is this correct?

It appears to be a VB related issue. I tried a C# version, ,ports match, app downloaded and installed missing items in Visual Studio, the app then opened.

I am a VB developer, I hope it works with that language.

Back to testing and troubleshooting

After a lot time spent on this issue the problem is Radzen has a problem with I can run a C# version and debug in Visual Studio. It runs as described and expected. If I create the same type of app with the only difference be choosing VB over C# it does not run. It does not download or install the components as described, It opens the console window and just hangs.

I am to the point where this certainly appears to be a Radzen bug. VB was a huge selling point for me. I hope we (Radzen) can get this sorted out.


John W

Hi John,

The problem was fixed and the fix will be part of our upcoming release tomorrow.

Best Regards,

Sadly the recent update did not fix the problem. I even create a new simple test .Net Core/VB app with the same results. It runs in RadZen but not Visual Studio.

Can you check if client/node_modules are downloaded? If not please clean the project from Build/Clean and try Run again.

Please post also your Visual Studio version and build number and if you have any any errors in the Visual Studio output window.

Do you have also Node.js installed and what version?

VS 2017 Community Edition v15.9.3 with Node.js Tools

Node.js v10.14.1.0

The project is simple build of a .net core app (VB). Accepting all defaults. It has a single page, default main layout, page name Home, included in navigation, marked as start page. Runs in Radzen (today's release), it does not in VS. It hangs on the console/command window.

There are no build errors reported, and unlike a C# app no activity in the OutPut/Build window.

I did as suggested clean and build. No success. I have rebuilt the solution, I have deleted the project file and the run again in Radzen to recreate it. No success.

I have done several restarts of the pc just to make sure the RAM was clean, no success. I really have spent a fair amount of time trying to sort this out.

If there are suggestions it would be appreciated, I am still leaning towards a software bug.

Hi John,

I think we found what's causing these problems with Visual Studio while everything works normally with .NET Core CLI. Please open the VB project (server/project.vbproj) with some editor (Notepad) and change the SDK from Microsoft.NET.Sdk to Microsoft.NET.Sdk.Web

<Project Sdk="Microsoft.NET.Sdk.Web">

We will release fix immediately!

Best Regards,