Register/Login error message

Using the latest AccountController published, when there is a problem with RegisterApplicationUser data, it will redirect to Login. I'm not so sure that would be the right place to redirect to, but regardless, I still don't see the error message:

If you have generated the latest version of the Login page you should have seen the following notification:

You check if the Login page is latest by inspecting the Load event handler:

It contains code that gets the "error" from the query string and displays it in a notification if it exists.

I actually don't get that event handler with 2.20.5, though I do get the revised AccountController.

You need to regenerate the Login page. Follow the instructions from here: Login Component/Generated - small issues

I did, Sir. Even tried deleting the entire project and starting over - no Load event handler on Login.

This is what's in the new login.json:

"events": {
"load": []

Make sure you are using the latest Radzen version.

I was using 2.20.5, now I have 2.21.0 - same result, no Load event in Login. I've started from an empty folder and recreated the project.

Can you confirm that you are creating a Blazor application (and not Angular)? Just created a new app, added a MS SQL data source, enabled security and the login page contained the required code.

That's right, those are the exact steps I'm using. I have not tried uninstalling / reinstalling RadZen however, it has simply upgraded in place. I guess I can give that a crack as well.

I will also try removing AspNet* tables from my SQL database, as those have always existed when attempting this. I don't expect that to be related, but you never know.

Can you send us the meta directory of such an application to

I found it, boss. I failed to mention I'm ticking the "Enable email confirmation" box, so I misled you about the steps.

If you have a different Login template for that option it may need updating as well. For now, I have the code to paste into the .json, yeah!

That was it! Nice catch.

My error messages are up now as well. I am sometimes using Visual Studio (because of a handful of edits to generated code), and it still had NuGet Radzen.Blazor v0.0.68. A simple update cured the mismatch.