RadzenTree issue

Hi,
I have a strange issue on using the RadzenTree component.
I load the items on-demand when the user expand a node.
It works perfectly, but now I would like to auto-expand the root node.

Here how I create the tree:

The ShouldExpand method, return true if the node is the root node.

It works, but without rendering anything.
What does it means when I say that it works?
It means that the ShouldExpand return true on the root then Razen correctly calls the OnLoadNodeAsync to load the nodes.
But nothing is rendered on the screen. I inspected the document, and there aren't any children.

But now a strange behaviour occurs.. On the top right of the page, I have a button with a radzentooltip. If I move the mouse over the button.. ta-daaaa The radzenTree draw all the children of the root node.

I put a breakpoint everywhere, but for sure nothing is called when the tooltip is displayed, and RadzenTree is drawn.

Any clue?

Here the inspection, after passing the mouse over the tooltip:

I tried to reproduce this problem in our online demo but things worked normally. Here is what I tested:

 <RadzenTree Expand=@OnExpand Change=@OnChange Data=@rootEmployees>
     <RadzenTreeLevel TextProperty="LastName" ChildrenProperty="Employees1"  
        HasChildren=@(e => (e as Employee).Employees1.Any()) 
        Expanded=@(e => (e as Employee).Employees1.Any()) 
      />
 </RadzenTree>

Hi,
your scenario isn't the same as I have.
maybe the children property? I don't use it. each node just know how many children has, without any collection to them.
the children of an expanded node are loaded using the Expand method.