Radzen using .Net core 2.0

Is there a way to change the .Net core version (to 2.0) when creating a new server side project? It seems the default version is 1.1 and can’t be changed.

Hi @DI_Robin_Olivaw,

.NET Core 2.0 is already in our roadmap however we are still waiting Microsoft to release officially OData for .NET Core 2.0.

Which features from .NET Core 2.0 are most needed for your project that are not available in .NET Core 1.x?

Best Regards,

I found that I had around 8 versions of .NET Core installed. I uninstalled all of them. I then installed .NET Core 2.1.101 SDK based on the current installation instructions:

Radzen’s MS SQL Server, MySQL and PostgreSQL support requires .NET Core 1.x SDK or .NET Core 2.x SDK to be installed

When I run my app, I get an error:

radzen: Generating code ...
radzen: Code generation done in 1706ms.
dotnet: Restoring packages ...
dotnet: Restore completed in 288.88 ms for D:\Radzen\CIP Radzen\server\project.csproj.

dotnet: Restore completed in 218.12 ms for D:\Radzen\CIP Radzen\server\project.csproj.

dotnet: It was not possible to find any compatible framework version

dotnet: The specified framework 'Microsoft.NETCore.App', version '1.1.0' was not found.

  • Check application dependencies and target a framework version installed at:


  • Alternatively, install the framework version '1.
    dotnet: 1.0'.

Hi Steve,

You get this error since your application is using .NET Core 1.x (the only option at the time you’ve created the app). If you want to use .NET Core 2.x and you do not have any custom classes in the server folder you can delete the entire server directory, change or add the serverVersion:“2” to you app.json and rebuild your application:

“serverProject”: true,
“serverVersion”: “2”,

Best Regards,

PS: There are regression problems with Data Annotations and relationships with EF Core 2.x and we are about to release as we speak new Radzen version to avoid them.

Thanks. I installed .NET Core 1.1.8 SDK as well for now. I tried creating a new app using .NET Core 2.1.101, but it didn’t return any data when I ran it. I don’t know if that has to do with the problems you noted in your post script.