Radzen dropdown don't allow me to type anything in the search

Radzen dropdown don't allow me to type anything in the search

   public class CodeValuePair
        public string Code { get; set; } = string.Empty;
        public string Value { get; set; } = string.Empty;
    public IEnumerable<string> _selectedDataValues = new string[] { };
    protected List<CodeValuePair> _availableData = new List<CodeValuePair>();

protected override void OnInitialized()
if (_availableData == null || _availableData.Count==0)
_availableData = Data.Where(x => x.Language == "en").Select(c => new CodeValuePair()
Code = c.Code,
Value = c.Values.FirstOrDefault(x => x.Key == "default").Value
<RadzenDropDown AllowClear="true"

It doesn't even allow me to type anything in the radzen dropdown search area. what am i missing here.

Is it disabled? Do you have some css or js code that might have somehow affected that element?

It doesn't allow TValue to be as string , it throws error cannot implicitly convert from Ienumberable to string . I tried giving TValue to IEnumerble it still didn't allow me to search .

Yes, that was stupid on my part. I edited my question :slight_smile:

I am able to select the things from the dropdown but for me to search it dont allow me to type anything there . I don't have any css or js for this element .

Do you at least have the pointer blinking (like you will start writing), when you click on it?

Nope i click there and it does nothing. it behaves like search don't even exists although i see the little search icon.

As if it's disabled. Have you inspected that input element in this situation? Something wrong there?

looks like below

input id="search3OuI30m96E" tabindex="0" class="rz-inputtext" role="textbox" type="text" onclick="Radzen.preventDefaultAndStopPropagation(event)" _bl_485944e5-3b4c-423f-b671-b425877d3149=""

and for the radzendrop down which don't have multiselt=true . looks like below

input id="search3gKRESN-ak" tabindex="0" class="rz-dropdown-filter rz-inputtext " autocomplete="off" type="text" _bl_87cdbc7f-3569-4af7-bf94-5ce681fdbdfd=""

both of them acts like as if it is disabled.

In browser devtools give that input css rule: z-index: 1000 (some number). I wonder if that will "unlock" the writing.

Nope, it didn't i kind of stuck with this problem from last 3 days and i can't understand why

Me neither. Is it the same on different browsers?

yes its same on all the browsers


If you try without that class (looks like a bootstrap thing) ?

Nope didn't it help though.

I found something interesting . I added a new radzen dropdown for the page which is not a modal popup ,it works fine but if i do the same thing in the modal popup page it doesn't work . same exact code.

Alright i fixed it basically i am opening Modal by saying Model.Show for some reason if i use this to open modal , dropdowns search wont work so i used DialogService,OpenModelAsync and now dropdown search works. lol .

This error is caused by Bootstrap implementation.

1 Like