Problem passing through parameters, when using navigate to

I've got a problem passing through parameters, when using navigate to.

Please see below steps:


  1. I put in an order number and then select find order. Which will navigate to another page, with parameter OrderRefNo

  1. I set a property to the parameter

When I run it and select button. I get:


Hi @spookyCol,

I tried to reproduce the problem in the attached Radzen app to no avail. The page parameter was correctly passed. Make sure your OrderMaintenance page does not require more parameters - optional parameters are not supported. (28.0 KB)

Weird. If I follow you example. And set property as orderRefNo (lowercase first letter 'o') instead of OrderRefNo. I get the following:

Followed your example and still get page not found.

Can you make my example behave as in your case?

Recreated your pages from example (exactly). I get:


However, when I run your examples, works perfect.

Can you post a picture of the URL when you get "Page not found"?


I asked you to check if that page is not using other parameters from other locations. This can be verified by inspecting the generated code - XXX.razor.designer.cs - check how many properties are decorated with [Parameter]

Sorry. I couldn't see any. I've attached the file incase I missed something. (1.9 KB)

This page does not have any parameter declared which is why it ends up with 404. Can you send us the declaration of the other page - the one that navigates to it? The JSON of the page should suffice.

Attached is the sales dashboard screen. The screen with the button calling the navigate to.

The order maintenance screen is the page being called. (3.2 KB)

interesting. If ${srchOrderNo} is set to "". It works. As soon as it contains a value e.g. "123" or "abc" you then get page not found.

On the order maintenance page I'm only setting it to a property. So to not complicate the issue.

Unfortunately we can't determine the cause of the problem. We will need your complete application in order to test it locally. You can send it to Delete the server/bin, server/obj and wwwroot directories in order to keep the attachment size within limits. Alternatively use a hosting service (Google Drive, OneDrive etc.)