Problem Inferring schema from SharePoint Online

#1

I am trying to set up our company's O365 SharePoint site as data source using the SharePoint API.

After setting up authorization and click next, Radzen authenticates and then displays the Inferring Schema activity spinner but never completes.

I have set up as Odata source and tried a couple of end points

Any Suggestions?

thanks,
michael

0 Likes

#2

Hi Michael,

Can you check for design-time errors in the log file described in this article:

Best Regards,
Vladimir

0 Likes

#3

@enchev

No errors logged to Radzen\log.txt
all I see is licence and update check.

michael

0 Likes

#4

Did you enable MSGraph access to your sharepoint list? We have a blog post showing how.

0 Likes

#5

I did connect to MSGraph in the past. but did not try accessing Sharepoint. So, I was going to give that a try again but i am now getting errors after connecting to the MS Graph API.

I followed the example. and it worked a couple of months ago.

I created a new application. connected to MS Graph. all seems to work. however when I run the application with nothing more than a blank main screen. it errors out.

lots of errors similar to

  • src/app/ms-graph.service.ts(4684,496): error TS1005: ';' expected.
  • src/app/ms-graph.service.ts(4708,606): error TS1005: ';' expected.
  • src/app/ms-graph.service.ts(4732,601): error TS1005: ';' expected.

not sure what has changed.
michael

0 Likes

#6

This seems to be an error that we have addressed with the latest Radzen release - Incorrect code generated for OData PUT methods.

0 Likes

#7

I'm running 2.13.3 is this this latest?

0 Likes

#8

The latest version that we released today is 2.13.4.

0 Likes

#9

ok, that works. thanks.

0 Likes