.NET core does not initialize in HTTPs

I have a HTTPs certificate, IIS is binding to https but no matter what I do, the radzen application on port 5000 refuses to use HTTPs. It always starts as HTTP. Even when I enable it as HTTPs mode on radzen the net core app does not start on HTTPs.

Ok so right now on my Program.cs the setup is like this

              .UseKestrel(options => options.Listen(System.Net.IPAddress.Any, 5000, listenOptions =>
                    listenOptions.UseHttps("certificatefile", "pass")))

Though when it goes to IIS the log says something along the lines of:
Ignoring set urls because PreferHostingUrls is on... Though I can't find at all where that option is set to true anywhere.
And then it defaults to http instead of Https.
This is how radzen wrote it when I set https to on, is there any further setting I must change?

When deployed to IIS those settings are ignored. You need to setup HTTPS at IIS level.

It is setup at IIS level, the main site in itself is running on HTTPs. What do I need to do for the final build to use HTTPs? No matter what I did up to know when it goes to IIS it uses HTTP. I have the certificate, I have it both on IIS and on the build folder.

Pulling my hair over the last 3 days because of this