Lookup popup only show 1 page

Hi,

I have a problem with lookup popup, and it exactly like this posting: Lookuppopup becomes gray when try to search

I create with new CRUD Pages wizard and got 3 pages: List, Add and Edit for the table. In the input page I change one field type from integer to lookuppopup and supply the required properties: Data, TextProperty and ValueProperty.

When I run the application and open the input page and click the field with lookuppopup, the popup appeared:
image
There are 10 rows of data because I dont change the initial PageSize (which is 10). But it only have 1 page (the table have almost 2000 rows).

Then I type the user I want to search and click the search button, the grid greyed out but nothing happen.

When I see chrome's developer console, there are no error, only warning that appeared eachtime I click the button:
image

And in the network tab, there are no new request. There's only initial request to "Users" that resulted all rows of user table.

Am I missing something? A property I have to fill?

In the post I mentioned above, I quote

This component cannot search in-memory and you need to invoke a data-source method.

On which event of the form that I have to "invoke a data-source method" ?

Edit: I tried to "console.log" on the foms LoadData event, and it firing when I click the button. So, I should see how radzen search the datagrid? Any hint?

Edit 2: My problem almost solved here: Lookup to big table (lookup and lookup popup) :slight_smile:

Any example really appriciated :sweat_smile:

Thanks.

You need LoadData where you should request, receive and set total records count and current page data. Check the code generated in Add/Edit Order Details for CRUD pages with our Sample database.

Yes, I find it in page with datagrid. All parameters I need is in event object. I just "console.log" the event object to find what parameters do I get from the action.

Thank you. Problem solved (I think).