Issue with Gauge Binding

I have an odd issue. I have a start of a dashboard page with 3 items currently, a grid, a label, and a gauge. The label is bound to the page property that returns the count of records in a grid. If I do not bind the gauge to any data or set it manually the page renders fine and give me a correct count of records in my label field. If I then bind the gauge to the same property the page renders completely empty.

Shows Dashboard with no binding on the gauge

Shows binding setup for the label field.

Shows adding the same binding to the gauge field.

Shows the result of adding the binding to the gauge.

Hi @joshwilliam,

Indeed there is a problem with the Gauge component which we have fixed. Until we release a hotfix you can set the Visible property of the Gauge to ${getDealsCNT}. This should mitigate the problem

That worked.



I have the same problem.
Can you confirm if is already solved at the moment ?

Hi @asousai9, the bug has been fixed shortly after the discovery. You could be seeing a different issue.


i have a stored procedure that gets the data and I can see the value on the console network.
The problem is with the binding of the data.
I can't see where can be the error