Infere schema and pluralization option


I am new to Radzen and plays around with it. Found something that looks like an error.

If I infer a schema and making some CRUD pages everything it works well, as expected. In Swedish the pluralization with “s” is not preferred.

I have a table called Konto. With pluralization it becames Kontos, and the link in the menu goes to /Kontos. Works well.

Without pluralization the name is Konto, that’s what I want it to be named. But the link from the menu will be /Konto-page, note the “-page” extension. That page doesn´t exist, the real name for the page is /Konto without the extension.


Hi Andres,

Just tried infer without pluralization using latest Radzen and everything worked as expected:


I can list, add and edit records:

Can you click on the menu item Konto? Thats the link that gives the wrong page.

Clicking on navigation menu works as well.

What is your Radzen version? Latest is 2.25.6.

Ok. I reproduced the problem for Blazor - I'll move this thread in relevant category. Fix will be included in the next version (before the end of this week).

I tested some more as well, it is just with the Blazor version.
Thanks for a quick response.