How to fix garbled text in Radzen IDE

Hi everyone.

I've just started using Radzen on Japanese OS, and I'm having the following display problem when I build a project created with Radzen.

I guess that it's a problem comes from Radzen IDE's default font settings against Japanese character output from dotnet system.

Is there anyone know how to fix it?

Thanks for the report! Do you have similar problems in Visual Studio Code? We are using the same component in our output pane.

Hi @enchev,
Thank you for your quick reply.

Is there a way to confirm it ?
I am ready to use Visual Studio Code.

Hey @Yukishige,

I'm not asking you to use Visual Studio Code but to try if there is a same problem since we use the same component.

Hi @enchev,
I have already set up Visual Studio Code with localization and confirmed that Japanese can be displayed without any problem.

Is this what you want me to confirm?

Hi @Yukishige,

Thanks! In this case the problem is somewhere else - we will research it and I'll post more info.

Thanks @enchev

The Japanese characters in the garbled areas are as follows

I hope there will be a good solution.

Yes, I was able to reproduce the problem locally (a bit different in my case) and we will look for solution:

How to change text encoding on an output window for Visual Studio 2017 (

It seems that the problem I am facing now is probably not a problem with font settings.
I copied the text in the Window and pasted it into Notepad, but the character encoding itself was already wrong.

dotnet: .NET ���� Microsoft (R) Build Engine �o�[�W���� 16.7.2+b60ddb6f4
Copyright (C) Microsoft Corporation.All rights reserved.

So I did a search and found the following information, which I believe is the same cause.

I have also experienced that the default character encoding on Windows for Japanese OS is S-JIS, not UTF-8, so if it is run as a console application, the resulting character encoding must be decoded as S-JIS or the character encoding will be destroyed.

Try to set globally for your Windows DOTNET_CLI_UI_LANGUAGE=jp-JP

Thanks @enchev,

I have tried both of the settings below.

Windows environment variable for system

With "jp-JP", dotnet output an error and with "ja-JP" did not cause an error, but did not fix the garbling itself.
(Of course, I have restarted the Radzen application in both cases.)

Please try also DOTNET_CLI_UI_LANGUAGE=en

Thanks, @enchev.


The dotnet application now outputs messages in English, so the problem has been avoided for that time.
I think the problem is still there, so I would appreciate it if you could notify me if it is fixed.

Good news! We were able to fix this and it will be part of our next update before the end of this week:

I've set DOTNET_CLI_UI_LANGUAGE=ja to test it.

Thank you for giving me a good news.
I am very much looking forward to its release.

Thanks, @enchev

The New version (Radzen 2.58.16) works fine!