Failed to load resource after deployment

The image is able to load if directly run from Radzen.
But it failed to load after IIS deployment.
And in the deployed wwwroot, the image file is located in [project]\wwwroot\en\assets\images

Thanks for the report! Fix will be released with our next update early next week.

Dear Enchev,

Would like to check whether the fixes already release?

Hi @cllor80,

Yes, the fix is already released:

Dear @enchev,

I just tested with the latest radzen 2.62.4, but the issue still persists.

Hi @cllor80,

Try in browser incognito mode or clear the cache. You can also inspect the url with your browser dev tools.

try with incognito mode, still not able to display the image asset.
I have put in localization, it generated C:\inetpub\wwwroot\cappv2\wwwroot\en\assets\images.
Is it normal for this generated deployment path? which have another level of wwwroot?

If you have Radzen subscription you can send us your application to test it locally.

I experienced the same issue using a demo app. RadzenCrm asset images failed to load, and I am not sure if it is loading from the correct directory as shown below. This same issue happens regardless if I deploy using Radzen in admin mode, or from Visual Studio in admin mode.

I don't know if its related, but I've fixed similar issues changing the 'do not copy' setting for the assets in Visual Studio. Locate the file(s) in Visual Studio solution explorer, and right click on them and select 'Properties' to change this setting.

Also, be sure the files are physically in the right directory on the web server, and verify the path to them is correct with your browser's development mode.

Its was set to "Do not copy" in VS2019 by default. I did not change anything.

Yes. And your environment looks to be different than mine, so I don't know if changing that would help as it did for me.

Dear @enchev I have the subscription. How do I send the application for you to test?

Hi @cllor80,

We've released yesterday new update with a fix that might be related to your case. Please test the latest Radzen and if you still have problems you can send us your application at If the application is too big you can upload it to Google Drive, One Drive or similar and send us a link.

Dear @enchev ,

Tested with version 2.62.5, still persist the issue.
Just emailed the our application to the

@enchev sorry, the issue is solved. just need to clear the cache.

I cleared the cache but the problem remained. I deployed the RadzenCrm app

Hey @margarito,

As far as I remember you are using Blazor not Angular. Please use proper threads!

That is so right! My apologies!