Error: Unable to load shared library 'hostfxr' or one of its dependencies

Hi, I am running on macOS Big Sur version 11.7.1 on Intel Processor. After I installed Radzen Blazor Studio, I tried to create a new project by clicking the + button "New Application...". It generated the following error message "Unable to load shared library 'hostfxr' or one of its dependencies. In order to help diagnose loading problems, consider setting the DYLD_PRINT_LIBRARIES environment variable: ". I deleted the application and reinstalled it several times, but it did not resolve the issue.
Also, I am running,
Version: 7.0.100
Commit: e12b7af219
Can you please help resolve this issue?

Hi @ganeshan,

This files seems to come from .NET. Make sure you have the right version for your OS and processor architecture of the .NET 7 SDK installed. Also ensure you have installed the SDK and not just the runtime.

any updates on this. i am having the same issue

Hi @Tobias,

We don't have additional information. This error seems to come from .NET SDK itself and not Radzen Blazor Studio.

Ok, that’s not very helpful.

Have you tried reinstalling the .NET 7 SDK on your machine? What is the output of executing dotnet --info ?

Can you also try running dotnet sdk check ? I found it via this issue: [Preview 4] dotnet sdk check fails when runtimes installed via script · Issue #54965 · dotnet/runtime · GitHub

This is what I got for dotnet --info
Version: 7.0.101
Commit: bb24aafa11

Runtime Environment:
OS Name: Mac OS X
OS Version: 11.7
OS Platform: Darwin
RID: osx.11.0-x64
Base Path: /usr/local/share/dotnet/sdk/7.0.101/

Version: 7.0.1
Architecture: x64
Commit: 97203d38ba

.NET SDKs installed:
6.0.100 [/usr/local/share/dotnet/sdk]
6.0.101 [/usr/local/share/dotnet/sdk]
6.0.102 [/usr/local/share/dotnet/sdk]
6.0.201 [/usr/local/share/dotnet/sdk]
6.0.402 [/usr/local/share/dotnet/sdk]
6.0.403 [/usr/local/share/dotnet/sdk]
7.0.100 [/usr/local/share/dotnet/sdk]
7.0.101 [/usr/local/share/dotnet/sdk]

.NET runtimes installed:
Microsoft.AspNetCore.App 6.0.0 [/usr/local/share/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.AspNetCore.App 6.0.1 [/usr/local/share/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.AspNetCore.App 6.0.2 [/usr/local/share/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.AspNetCore.App 6.0.3 [/usr/local/share/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.AspNetCore.App 6.0.10 [/usr/local/share/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.AspNetCore.App 6.0.11 [/usr/local/share/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.AspNetCore.App 7.0.0 [/usr/local/share/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.AspNetCore.App 7.0.1 [/usr/local/share/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.NETCore.App 2.0.9 [/usr/local/share/dotnet/shared/Microsoft.NETCore.App]
Microsoft.NETCore.App 6.0.0 [/usr/local/share/dotnet/shared/Microsoft.NETCore.App]
Microsoft.NETCore.App 6.0.1 [/usr/local/share/dotnet/shared/Microsoft.NETCore.App]
Microsoft.NETCore.App 6.0.2 [/usr/local/share/dotnet/shared/Microsoft.NETCore.App]
Microsoft.NETCore.App 6.0.3 [/usr/local/share/dotnet/shared/Microsoft.NETCore.App]
Microsoft.NETCore.App 6.0.10 [/usr/local/share/dotnet/shared/Microsoft.NETCore.App]
Microsoft.NETCore.App 6.0.11 [/usr/local/share/dotnet/shared/Microsoft.NETCore.App]
Microsoft.NETCore.App 7.0.0 [/usr/local/share/dotnet/shared/Microsoft.NETCore.App]
Microsoft.NETCore.App 7.0.1 [/usr/local/share/dotnet/shared/Microsoft.NETCore.App]

Other architectures found:

Environment variables:
Not set

global.json file:
Not found

Learn more:
dotnet command - .NET CLI | Microsoft Learn

Download .NET:
.NET Downloads (Linux, macOS, and Windows)

We may have fixed this problem. The fix will go live with the next release (probably tomorrow).

After the update to 1.1.0, I can finally run Radzen Blazor Studio. Thanks for fixing it. I only have 11 days left in my trial. :frowning: