Edit pages not loading dropdowngrid data

I'm new to Radzen and am not sure what I could have done to cause this behavior on all of my Edit pages.

This was all working perfectly until yesterday.

Now when I click on row in my grid to Edit, the page opens, then it looks like it does this refresh and as it reloads all of my fields that are dropdowndatagrids (links to other tables) are coming up blank.

I can imaginge I'd do somethong on a page to mess something up but this issue is happing on all of my Edit pages where there is a dropdowndatagrid field. The only changes I made (that i know of) were the PageSize and I checked the Allow Clear on these dropdown fields. I reverted these changes back, but issue is still there.
I have a video of the behavior but it won't let me upload so I've attached the screen with my missing dropdowndatagrid fields. Also screenshots of properties for the Product dropdown and the page Load Event with all the expands in place.

Hi @lindaharris,

Does it work if you downgrade Radzen? You can download an older version from here: What's new

Thank you for the quick response! I downgraded to 2.68.9 and it is still behaving the same. So must be something I did. :frowning_face:
I've looked at my Edit Pages in VisualStudio and did a compare, to previous working version, the only changes I see are those I mentioned earlier. I'm not sure where else to look.

Check your browser console for errors, this can prevent the page to load data.

The only thing the console was giving me was an uncaught syntaxerror unexpected identifier 'pagefile' has already been declared.

I know I wasn't giving you much to go on. So I went ahead and rolled my changes back to my last checked in changes. Everything is working again. Yay!!
I will do small changes and test going forward. That way I'll know what changes cause the issue next time. :slight_smile:
Thank you very much for all your support!!

Well, it worked when I ran it from Visual Studio. Then I ran it from Radzen IDE and it broke again. ugh...
In the browser console there are no errors. I've attach the console log. Maybe you can see something it is or isn't doing right. I hope.
localhost-1653075123539.zip (765 Bytes)