DropDown not working with enum & multiple selection


In Radzen 4.16.4 the DropDown component is not working if Enum typed data with multiple selection is used. The DropDown is rendered but it isn't possible to select any option.

The folowing snippet can be used to reproduce this behaviour:

<RadzenDropDown TValue="List<Color>"
                Multiple=true />

@code {
    private List<Color> selectedColors = new();
    private List<Color> allColors = Enum.GetValues<Color>().ToList();

    private enum Color

Is this a bug or is something wrong with the code?

Should be @bind-Value.

Oh :man_facepalming:

Thank you!

After fixing the typo everything works fine. I wonder why it worked before updating Radzen dependency, though.

Such syntax never worked for any bound Radzen component.

I've tested the code above with lower case 'v' using Radzen version 4.15.7. Selecting options works without any issues.

But nevermind. Lower case spelling is obviously wrong and the DropDown is working with correct spelling and latest Radzen version.

Again, thank you for your support!

This is definitely not true, and I'll restate as many times as needed.