Deployed WASM (Production) not compressing Radzen js/css

Hi All

I have noticed after deploying my Radzen project that the files specific to Radzen do not appear to be served as compressed files.

For example the following files are brotli compressed:

BUT.. the following Radzen are not:

Also of interest is the brotli compressed files have "Blazor-Environment: Production" response header, yet the Radzen files do not.

Example screenshots:

Is there something I can do to have all files in the Radzen project compressed.
Note, this is a Radzen Blazor Studio project (WASM)

Compression is enabled by default for _framework folder and it was shortly for wwwroot as well however later removed - according to this issue since there is no real benefit:

Considering the GH issue this looks as a generic Blazor nuance. You should probably log a new issue in the aspnetcore repository.

Oh :frowning: that is a pain.
I really appreciate the speedy response though.

It greatly increases the size of things like fluent-dark-base.css which comes in at a whopping 636Kb alone.

I think I will log an issue.

Thanks again.

I think you can enable asset compression easily at web server level. This is probably the correct approach anyway. It is enabled on our demo site and all assets are compressed.

By the way the Fluent Dark theme is a premium one - make sure you have an active subscription if you use it in production.

I'm not sure I can change AWS App Runner runtime compression settings unfortunately.
I also deployed to Fargate as well but no luck there either :frowning:

And yep, no trouble with "Fluent Dark theme" you will see I have a paid subsciption :wink:

There is probably some hidden setting - all web servers worth their money have it (Nginx, IIS, Apache). Otherwise I would look for a different provider :wink: Dynamic asset compression is a common feature.

I just verified your subscription and marked your forum user as customer!

1 Like