Deploy To IIS

I deployed my app to IIS and the output showed no errors and was successful but I get the below error when trying to display in the IE 11 browser. Any idea how I can correct the issue?

HTTP Error 500.19 - Internal Server Error

The requested page cannot be accessed because the related configuration data for the page is invalid.

Hi larrywhite,

You may need to give access to the IIS_IUSRS group or IUSR user for the application folder. Please verify also if you have IIS URL Rewrite module installed - this is needed because of Angular/HTML 5 routing.

Best Regards,

Hi larrywhite,

Please post also the Radzen log file for this application:


Best Regards,

Vladimir, there is no *.log file in this location.

Vladimir, I install the URL Rewrite Extension and gave IIS_IUSERS fill access to the application folder and still get the same error.

According to the IIS deployment documentation this error could occur if .NET Core support isn’t installed on that server:


  • Confirm that you have enabled the proper role. See IIS Configuration.
  • Check Programs & Features and confirm that the Microsoft ASP.NET Core Module has been installed. If the Microsoft ASP.NET Core Module is not present in the list of installed programs, install the module. See Install the .NET Core Windows Server Hosting bundle.
  • Make sure that the Application Pool > Process Model > Identity is set to ApplicationPoolIdentity or your custom identity has the correct permissions to access the application’s deployment folder.

Finally invalid web.config could also cause that. Could you paste here the web.config from the %SYSTEMDRIVE%\inetpub\wwwroot[APPLICATION_NAME]\ directory (the one Radzen created)?

Problem solved. I first install ASP.NET core 2.0 put got error it needs ASP.NET 1.1.0. I installed ASP.NET core 1.1.4 and the application renders.

I'm having a similar problem I think. I'm trying to publish to IIS and getting an error when trying to access the site:

Any ideas what might be wrong?
Thanks, Dan

The error message says that this configuration section is locked by a parent config file.

Would that be in the folder structure or some other setting? I don't see a web.config file in the wwwroot folder.

Can't really tell that - you have to check to be sure. I suggest searching online for this error message. For example here is the official documentation:

Also the answers in this thread could be helpful:

There seems to be a problem with the web.config file. I removed this:

 <remove name="WebDAVModule" />

And the error goes away.