DataGrid DeSelect Row


After updating to Radzen 3.1 select a row on second or later page of a datagrid then select another row. The first row does not deselect. Clicking other rows just adds to the selected rows. This does not happen on the first page or in previous versions of Radzen.


Hey @dfabrizi,

This can happen only if you’ve enabled multiple selection - check our demos for reference.

Thanks. Not sure why the behavior is different for the first page versus all other pages. I tried setting SelectionMode="DataGridSelectionMode.Single" still not deselecting rows on second and subsequent pages.. Rolled back to Radzen 3.0.10 and the issue does not occur.

You don’t have to set it - this is the default value.

Can you reproduce the problem on some of our grid demos?

So far no luck with your demos. If I change SelectionMode to Multiple on my datagrid I am able to deselect rows on all pages after selecting a second row. If I set it to Single or leave it undefined it just keeps adding to the selection on any page except the first page.

If you have Radzen subscription you can send us your application to to check what’s going on.

Don't have a subscription but for the Proof of Concept I'm working on I can live with the behavior.