DataContext issue from code generation?

When I run the project from Radzen for WA, I'm getting the error

the type or namespace name 'datacontext' does not exist in the namespace

When I go into the project in visual studio I can run 'Sync Namespaces' after right clicking the project and I can rebuild it in VS. And then it will run successfully.

Once I run the project again from Radzen it will generate code and then cause the datacontext issue to occur again.

I'm using 2.69.3 version

Update: The issue does not occur with Blazor Server Side

Hi @_Daniel,

What is the name of the data source? Radzen uses it to generate the data context name. You can send us your application to but be aware we have a 10mb size limit of emails.

Hi Korchev, the data context name is workworked.

The full error is:
error CS0234: The type or namespace name 'DataContext' does not exist in the namespace 'Workworked.Controllers.Data' (are you missing an assembly reference?)

Edit: I made a new app using blazor server (same db) and the name is workworkedserverside instead and that is working but Ideally I'd want this to work in the webassembly version.

How is your datasource named in the web assembly application?

The datasource is named data

Issue confirmed! Fix will be published with our next update tomorrow.