Custom WebAssembly property

I created a new property in models. I also created a partial class to populate this new property.
However, when I run the application, the value of this new property does not appear in the data GRID.

See a simple example:

-- Extend MODELS
public partial class KitProdutoItem
public intProductDescriptionCustom

-- Extend Controller

 public partial class KitProductItemsController
      partial void OnKitProductItemsRead(ref IQueryable<Models.StockBd.KitProductItem> items)

         foreach (var item in items)
             item.DescricaoProdutoCustom = 1;


When I run the application, the value 0 is displayed instead of 1. Knowing that 0 is the default value for INT. If I put a property of type string, nothing is displayed.

What is described in the DOC above doesn't work for me.
The value of "items" returns result but does not show on screen. It has no error. The property is displayed in the grid without values.

Do you have any suggestions?

You can try this thread as I think NotMapped is making OData ignore the property: Calculated fields on the server side

Its Work!

Thank You!