Can't create app using Radzen Studio on m2 mac

I noticed it is an app meant to run on intel machines, but I'm curious to know if I can create an app on m2 chip as well? It opens fine, but whenever I hit the create button it does nothing, even with the .net version installed (6 and 7). Do I have to use the Radzen Blazor Studio version instead since it is meant for m1 chip? I use a Macbook Pro M2 model with the latest OS version (Ventura 13.2).

Hi @BustosAndrew,

We are successfully running Radzen on M1 mac (the one I am currently using) via Rosetta. Not sure why it won't work on M2 and can't really test that.

Only Radzen Blazor Studio has a native M1 build.

I ran into a similar problem on a LG Gram running Windows 11. I figured out that I needed to run as admin to be able to create a new project. I'm not sure if I need to open radzen with sudo on my Mac to create a new project. Also, on the Mac, it couldn't recognize that either .net versions were already installed. @korchev

The main issue is that it's not detecting the installed .net versions, even if opened with sudo.

Can you show us the output of running dotnet --info?

 Version:   7.0.101
 Commit:    bb24aafa11

Runtime Environment:
 OS Name:     Mac OS X
 OS Version:  13.2
 OS Platform: Darwin
 RID:         osx.13-x64
 Base Path:   /usr/local/share/dotnet/x64/sdk/7.0.101/

  Version:      7.0.1
  Architecture: x64
  Commit:       97203d38ba

.NET SDKs installed:
  6.0.101 [/usr/local/share/dotnet/x64/sdk]
  7.0.100 [/usr/local/share/dotnet/x64/sdk]
  7.0.101 [/usr/local/share/dotnet/x64/sdk]

.NET runtimes installed:
  Microsoft.AspNetCore.App 6.0.1 [/usr/local/share/dotnet/x64/shared/Microsoft.AspNetCore.App]
  Microsoft.AspNetCore.App 7.0.0 [/usr/local/share/dotnet/x64/shared/Microsoft.AspNetCore.App]
  Microsoft.AspNetCore.App 7.0.1 [/usr/local/share/dotnet/x64/shared/Microsoft.AspNetCore.App]
  Microsoft.NETCore.App 6.0.1 [/usr/local/share/dotnet/x64/shared/Microsoft.NETCore.App]
  Microsoft.NETCore.App 7.0.0 [/usr/local/share/dotnet/x64/shared/Microsoft.NETCore.App]
  Microsoft.NETCore.App 7.0.1 [/usr/local/share/dotnet/x64/shared/Microsoft.NETCore.App]

Other architectures found:

Environment variables:
  Not set

global.json file:
  Not found

Learn more:

Download .NET:

Why is the architecture reported as x64? This seems wrong - it should be arm64. Here is how the output on M1 looks like:

Runtime Environment:
 OS Name:     Mac OS X
 OS Version:  13.0
 OS Platform: Darwin
 RID:         osx.13-arm64
 Base Path:   /usr/local/share/dotnet/sdk/7.0.101/

  Version:      7.0.1
  Architecture: arm64
  Commit:       97203d38ba

I’m not sure. I think that’s the way it is for M2 chip. Actually let me check again.

My apologies. I mistakenly downloaded x64 instead of arm64. Everything works now.

No, worries! Glad it worked out in the end.

1 Like