I made a pull request about the compare method not being the same as one in the EditRow and made a pull request.

Now this is sadly returning an error in the latest release :frowning: (System.NullReferenceException: 'Object reference not set to an instance of an object.')

canyou solve this ?

I do need the functionality to work like the one in EditRow if this is possible :pray:

Looks like I've accepted your change without proper testing - I'll remove your code and will publish update.

Sadly I assumed something and didn't test it either.
Sorry !

Thank you for the update.

The error is gone but the item is not removed from the editedItems and editContexts. I think this is because it doesn't use the RadzenDataGrid KeyProperty to remove it from these collections.

Actually it will be removed. You can debug our demo for reference:

It does work using normal data but I am working with dynamic data and then it doesn't work.

I should have mentioned that, sorry.

Not sure what are these dynamic data however it will work in our dynamic data demo as well.

In my case it doesn't work the displaying of the data works fine but as soon as i want to edit it breaks in the EditRowInternal method.

This is my dynamic data (from a method inside my viewmodel)

Yesterday i thought i had solved it by using :point_down: and setting the RadzenDataGrid KeyProperty to the Key property

That worked I could edit but then if I Canceled the CancelRowEdit method didn't work.