Bug when creating new app OOB

So I'm checking out different possibilities of using the built in security but there appears to be a bug in the generated code for creating namespaces.

Steps to reproduce:

  1. Create a new Blazor App
  2. Create a new Database using SQL, I called mine dbRadzen.
  3. Setup Security using Default and generate pages, no email setup needed.
  4. Run, you should get an error about not finding dbRadzen in the namespace.

This is using the latest version as of today.

Just tried that however it worked for me:

Can you post more info in which file there is compilation error?

Thats weird... see the screen shot. Sorry, I cant upload the project as a ZIP it seems.

If you own Radzen license you can send us the project at info@radzen.com.

I only downloaded it 2 days ago to evaluate, do you want me to email to you as there must be some issue as that was clean project.

Are there any tables in the dbRadzen database?

No, i created a new db for the purpose of this test.

This is probably the issue. Try adding some tables. We will look into addressing that.

I added a table to the db with a single PK column but no data and then edited the data source and hit Infer Schema again. Ran the project and got the same error...

Tried to delete the datasource to re-create and got this error.