Blazor CRM Tutorial issues

Hi there,
I was trying to follow along the blazor crm tutorial but i stumble upon some problems.

First problem : Add Application Role
I get a error Cannot create role Role name '' is invalid.

I figured out how to fix it , the textbox on the Add Application Role has no Value and the tutorial did not mention i had to edit it.I added ${role.Name} as value and that fixed it.

Second problem : Add Application User
After filling in everything and after clicking the save button nothing happens i also do not get any error the app just freezes.Have double checked if all the textboxes and the file input has the correct values and i don't see anything missing.

Can't get further on the tutorial due to this so it would be nice to figure out whats wrong.

Hi @beat,

We are aware of the first issue and it is caused by a regression in the page template that we are going to address with the very next Radzen release.

We are not sure about the second issue. Check Radzen's Output window for exceptions. Alternatively run the application from Visual Studio and break with a debugger in the SecurityService.

Thanks Korchev!
I managed to find the second problem and for some weird reason the Name of the password field was changed and that resulted to "can not find the Password component".
A bit ashamed that i missed that when i double checked the row values but , it's working fine now and i can go further with the tutorial.

I think i found another problem.
The problem is in the file server\Services\CrmService.Custom.cs.
I get a error after adding this line ''items = items.Include(item => item.User);''

The error is
Error|CS1061|'Opportunity' does not contain a definition for 'User' and no accessible extension method 'User' accepting a first argument of type 'Opportunity' could be found

There is no item.User however there is item.Name but that does not work.

In the example "Here is how it should look like:" there is a typo , after
items = items.Include(item => item.User) the semicolon is missing.It's showing correct in the line above but not in the code block.

This is covered the Create Foreign Key section.

I almost got it done but i am stuck on the next problem.
Microsoft.EntityFrameworkCore.DbUpdateException: An error occurred while updating the entries. See the inner exception for details.
---> Microsoft.Data.SqlClient.SqlException (0x80131904): The DELETE statement conflicted with the REFERENCE constraint "FK_Opportunities_AspNetUsers". The conflict occurred in database "CRM-Cube", table "dbo.Opportunities", column 'UserId'.
The statement has been termina

I get this when i want to delete a user.

I think this happen after i ran the sql script with the test data for the dashboard.
if i create a new user i can delete but i can't delete the the 2 users imported from the sql script.
Tried to manual delete them from the database but same problem.

If anyone gets stuck at this part then don't use the sql script for the dashboard data.
I fixed my problem with deleting the database and instead of using the dashbord sql script i manual added the data and problem solved.

Next problem.
After adding all the datagrids on the dashboard the Active Tasks datagrid is not showing anything under the Employee column where it;s supposed to show a image,first name and last name.All the other columns are showing data.

Checked the template and it should be working , intellisence is working when i type ${data.Opportunity.User.Picture on the image and ${data.Opportunity.User.FirstName} , ${data.Opportunity.User.LastName} for the labels.

Does anyone have a idea on why it's only the employee column not showing any data?