Blank screen after manual deploy

Hi guys,

I'm one of your community users.

I deployed my Blazor sample manually following your instructions on this ( page.

Everything went well. But when I open my page it was blank.

When I checked the devtools I saw two messages about Normalizing passed and the WebSocket connected.

Where must I dig for this situation?

Thanks for your help,
Köksal BAŞAR

We are not sure what can cause such problem. Check for log file with errors.

Hi Enchev,

Where is the log file? I could not find any *.log file under Radzen Project directories.

I gave up the previous project and create a brand new one project that includes only one table. I did the publishing process step by step again. The result was the same with the previous one.

I want to emphasize these points again;

  1. While the publishing process, I didn't face any error message.
  2. When I inspect the published page there was no error message again and I saw the two informations one of about normalizing and the other one about WebSocket.

The log file is mentioned in the Troubleshooting help article.

We also recommend referring to Microsoft's deployment documentation as manual deployment of Radzen applications is exactly the same.

Hi Korchev,

The first log file (%APPDATA%\Radzen\log.txt) mentioned in the document contains Radzen's working or debugging information as I understood.

I've deleted the previous one and run then Radzen. But the file was showing only the license and upgrade checking information. This is what I expected because there is no error. This file can't change while I try publishing. Because I've been working on Visual Studio at that time.

The second log file (%SYSTEMDRIVE%\inetpub\wwwroot[APPLICATION_NAME]\radzen_#####_##########.log) did not be created. Because I've not been using the Radzen for publishing.

There is the last chance for finding the problem is JavaScript errors. But as I wrote before there are only two lines.

  • [2020-08-23T18:07:34.439Z] Information: Normalizing '_blazor' to ''. blazor.server.js:1
  • [2020-08-23T18:07:35.092Z] Information: WebSocket connected to wss://

And addition; when I stop the webserver the errors appear immediately and the web page shows "Attempting to reconnect to the server..." message. The previous two lines are coming back after restarting the server and clicking the "reload" on the page. So everything seems working well except displaying the page.

  • I published directly to the web site.
  • I published it to a folder instead of the first option.
  • I copied the debugging files instead of the release files.
    But nothing is changed.

I really not know what must I do.

Check if you have latest .NET Core 3.1 Windows Hosting bundle installed.

@koksal.basar there is still some misunderstanding and I really recommend reviewing Microsoft's deployment documentation when you don't want to use Radzen's built-in deployment feature.

  1. The manual deployment procedure isn't specific to Radzen. It is the default procedure to deploy a .NET Core application. All Radzen applications are .NET Core applications and there aren't any additional steps required. Thus all resources available online are valid for a Radzen application.
  2. The %SYSTEMDRIVE%\inetpub\wwwroot[APPLICATION_NAME]\radzen_#####_##########.log file isn't created by Radzen. It is created by IIS when running the application and configured in the web.config file.
  3. The log you see in the Browser console is not Radzen specific - it is Blazor.

The last thing I can suggest is to make sure you have deployed the complete contents of the server\bin\Release\netcoreapp3.1\publish directory and not just the wwwroot directory that's inside it. What I observe online with your website will happen if you have deployed only wwwroot.

Yes. .NET Core 3.1.7 - Windows Server Hosting is already installed.

Hi @korchev,

I'm sorry for the misunderstanding about the log files. When I read the specific path in the document I didn't check other locations for the log files. Because of my configuration, all the log files are the same place. I changed my configuration and the files didn't give me the special information. I think I do not have enough information about this.

I added the log here. If you see something specific point let me know. If there is nothing special please don't waste your time on this issue.

For the info, I already tried this kind of tricks.

I'll recheck all the documents and configurations etc. with googling. If it's not a Radzen specific problem so it must be a known problem. If I found something I'll make you informed.

Update : I created a Blazor application in VS2019 and published. Everything worked well.

Here is the log;


Hi guys,

I really gave up.

I couldn't find useful information to solve my problem.

I'd checked all the stages of preparation of .Net Core publishing.
I'd reinstalled prerequisites.
I'd created a new and basic Radzen project.
Nothing worked for me.
In addition, when I create a Blazor project I can publish it seamlessly and it works fine.

I could not access any error message on the server-side neither while publishing nor after publish.

There is only the following warning messages are created by the compiler. But the application is running without error both Radzen and VS. (I didn't care so much these warnings actually because of these pages are created by Radzen.)

server\Pages\XXXXXX.razor.designer.cs(78,13,78,27): warning CS4014: Because this call is not awaited, execution of the current method continues before the call is completed. Consider applying the 'await' operator to the result of the call.

I'll be around here and try to time to time publishing again.

I want to thanks @Benjamin_Fadina. He is a great man.
I solved this problem with Benjamin's following tutorial.

This is a very interesting detail but it's worked for me.

When Benjamin has been creating a website he used an IP address (select a default one) instead of a domain name. But I was using a domain name.

Why Radzen manual deploy is not working with a domain name? who cares? It's working now.

Thank you Benjamin one more time.


After Benjamin's tutorial, I checked out my configuration. Domain name problem comes from one of Cloudflare's free domain redirect service. My domains are forwarding to HTTPS directly. It seems a problem in this case. But can solve easily.

So this case closed.

So this wasn't related to Radzen after all ...

For this, I shared the previous post proof of there is no problem related to Radzen.

If somebody faces a similar problem can check out this kind of cause.