Blank app on IIS after manual build and deploy

Hi! I'm using Radzen Community Edition and I tried to manually deploy app to my IIS server. I followed instruction from Manual Build and Deploy in Documentation section and everything went without errors but for some reason I got blank app (only Favicon and app name is loaded and if I visit website from my phone it only loads name, favicon and theme header color).

In web browser's development tool in network tab I can see document and favicon with status 200.

What can I do to solve this?

Hi @gotik911,

Can you post a screenshot from the files of your deployed app. I suspect that .NET Core app is missing/not deployed.


This is screenshot... in wwwroot is content from client\src folder of my app

It’s correct! What base-href you have used for the Angular app? It should be /petroprojekt. Can you post also screenshot from your browser network tab?

I used my mikrotik router public static IP address redirected to port 1433 for MSSQL and port 8080 for IIS website to connect Radzen to my database and later after deploy to load my webapp (I add port to IP address in browser url).

When I run app from Radzen it loads data from my server using public static IP address.

Any errors in radzen_#####_##########.log file located in the root folder of the deployed application?

Actually no! I even don't have such log file. But everything works if I run app locally from Radzen and if I use ng serve --prod

Do I have to edit Web.config in WebApp root file?

If you don’t have it there are no errors. You do not have to edit anything else. What base-href you have used to build the Angular app?

I haven't used anything but .\node_modules.bin\ng build --prod

That’s the problem! You need to specify base-href when building the Angular app:

--base-href /petroprojekt

Is it enough to only re-upload client\src folder or I have to build and deploy everything?

You can update the Angular app only located in wwwroot/petroprojekt/wwwroot.

Unfortunately, it's not worked. I changed port to 8081 just in case and tried to load app using IP:8081 and IP:8081/petroprojekt but in both cases it's the same blank page.

This happens if I try to load app locally on server:

I'll try to build and deploy everything again.

Hi @gotik911,

I've checked the url you've sent me and it seems that the app is working as expected now:

Best Regards,

Yes. Thank you so much for help! The problem was that I used files from client\src folder insted of client\dist folder

It seems that I wasn't read documentation carefully.

Anyways.... your support is amazing!

Best regards,

1 Like