Application not working with MySQL on webserver

I have created a simple application using Radzen with a mysql database (This was done on a mac with local mysql server running) the application runs fine and as expected.

When i deploy this to my webserver (Centos 7 with mysql server running) i can get the pages to display but with no data. I have tried a few things but am out of ideas.

I ftp the files from the deploy folder to the root directory on the web server.

Am i missing something?

Thanks in advance

Hi! What is the web server you use to deploy on Centos? You can check its output logs to see if any exception isn’t thrown server-side. One of the common reasons is incorrect connection string. The app.settings.json file should contain the connection string used in production.

Web server is Apache on linux (Centos 7.4). After i did a manual build using (./node_modules/.bin/ng build --prod) i uploaded the contents of the dist folder to server only (under client).

I don’t see that file, a file called appsetting.json exists in a folder called sever that isn’t uploaded but that only contains :-

“Logging”: {
“IncludeScopes”: false,
“LogLevel”: {
“Default”: “Debug”,
“System”: “Information”,
“Microsoft”: “Information”

when i did the deploy method then copied the contents of the deploy folder a file named appsettings.json was there, with some form of connection string… but this didn’t work, so i went for the manual way.

Thanks @dodds_uk. The MySQL access is provided by an ASP.NET Server application which you need to also deploy on your server. The application is generated in the server directory. Normally the FTP Radzen build should do everything for you. Instructions for deploying an ASP.NET Core application with Apache can be found here: You will have to install .NET Core 1.1 for Linux on your server.

Hi @dodds_uk,

We've added Deploy to ZIP option:

You just need to specify the url where your app will be hosted and Radzen will produce file in your application folder with everything needed.

This feature will be part of our upcoming official release(before the end of this week)!

Best Regards,

Thank you for adding deploy too zip…

I have .net running on server, and connection string is correct, but i still see no data from the database…

Do you have a document or procedure for deploying to a linux/apache mysql server.

I must be missing a step somewhere.

How do i run the test app (start the localhost:5000) from the terminal?



Please verify browser console for errors as shown in this article (runtime errors):

We will do our best to provide deploy instructions for Linux/Apache soon.

If you want to run the app locally you can use either Radzen or manually call npm install + npm start for the Angular app (client directory) and dotnet restore + dotnet run for the .NET Core app (server directory).

Best Regards,