Application does not build

This just started happing to me "Application does not build" with the errors shown below using version 1.8.1. I am unable to use the application to edit any pages.

To confirm that the issue is not from existing code I did the following to test.

  • Created a Blazor Server application.
  • Connect to SQL Server with 1 table.

Generate a page from 1 table. I am getting the following 2 errors CS0115, CS0311 all of a sudden.

EditAccount.razor.cs(38,39): error CS0115: 'EditAccount.OnInitializedAsync()': no suitable method found to override
Accounts.razor.cs(50,39): error CS0115: 'Accounts.OnInitializedAsync()': no suitable method found to override
Accounts.razor.cs(63,33): error CS0311: The type 'FS.PaymentShield.Web.Pages.EditAccount' cannot be used as type parameter 'T' in the generic type or method 'DialogService.OpenAsync(string, Dictionary<string, object>, DialogOptions)'. There is no implicit reference conversion from 'FS.PaymentShield.Web.Pages.EditAccount' to 'Microsoft.AspNetCore.Components.ComponentBase'.

1 Like

Can you build this application normally using dotnet run or Visual Studio? What’s your .NET SDK?

Yes the apps continue to build fine in Visual Studio 2022 and Visual Studio 2022 Preview.
The issue appears to be with .NET version 7.0.5 that was recently installed versus version 7.0.4.

C:\Program Files\dotnet\packs\Microsoft.NETCore.App.Ref\7.0.4
C:\Program Files\dotnet\packs\Microsoft.NETCore.App.Ref\7.0.5
C:\Program Files\dotnet\sdk\7.0.203
C:\Program Files\dotnet\sdk\7.0.300-preview.23179.2

Such errors could happen if you generate the page once with codebehind enabled and once without. You can try creating a new application and add a page. If you still experience problems you can send us your application to

Just made a sample application and sent it.

We haven't received anything from you. Try deleting the bin and obj directories to keep the app size smaller or use some cloud storage service to share the app with us.

Just sent again a smaller one.

Hello All,

I am providing the following update for others just in case they have the same issue. As we all know one should not use preview software on a production PC.

Microsoft broke "SqlPackage.exe" in an update to Visual Studio 2022 version 17.5.0. At that moment Microsoft acknowledged the issue and recommend users install Visual Studio 2022 preview to get a working "SqlPackage.exe". I deploy databases daily using "SqlPackage.exe".

The .NET version provided with Visual Studio 2022 preview 2 worked fine with Radzen Blazor Studio.
C:\Program Files\dotnet\sdk\7.0.300-preview.23122.5

Visual Studio 2022 preview 3 released April 11, 2023 created issue with Radzen Blazor Studio.
C:\Program Files\dotnet\sdk\7.0.300-preview.23179.2

Removing Visual Studio 2022 preview 3 resolved my issues I was having.

Again, one should never use preview software on a production PC.


I can confirm that following this instruction worked for me as well. Both were on Development PC's, so often work with pre-release software, especially now.

I ran into that issue as well. Thanks so much @kkluth for diagnosing this. I am running Radzen Blazor Studio 1.9.6 and was getting those same errors (CS0115, CS0311) as soon as I upgraded to Visual Studio 2022 version 17.6.0. I rolled back to 17.5.5 (the previous version) and the errors went away. Visual Studio did not display the errors in either version and Radzen performed fine as well. It was just that the Design view in Radzen was broken after upgrading VS to 17.6.0 (because of the "errors"). Yes, I can simply just edit the razor page in Source View, but I find the instant feedback of Design View was a big productivity boost and selling point for me.
Again kudos to you @kkluth and kudos to the Radzen Team for putting together such a productive tool (and maintaining it almost daily).

1 Like

This seems to be caused by: Blazor breaking change in 7.0.302 SDK? Β· Issue #8718 Β· dotnet/razor Β· GitHub

I am currently trying to make Radzen.Blazor and RadzenBlazorDemos compile and run as expected with .NET 7.0.302.

Radzen Blazor Studio doesn't work with .NET 7.0.302 as well. We will release an update later today.

1 Like

Hi community, I am experiencing an issue with RBS and wondering if it's unique to me or if other users have also seen it. If you have experienced it please reply to let the Radzen team know.

I make changes to my project using the RBS dev tool and save the changes. When I then click the Run button RBS displays the message "Application does not build", yet the application runs perfectly well and builds in VS. Closing RBS and re-opening the project is the only way to make the message disappear. This occurs seldom and randomly with no way to reproduce it in a systematic way, but often enough to be annoying.

What a fantastic product otherwise! Thank you Radzen!