Add new page fails in latest build

With the latest release of Radzen Blazor Studio, when I right click the Pages directory then select "New Page", the screen to select a template briefly pops up and then disappears before I can select a template and create the page. Any ideas what's going on?

Here's the build info from the help:



We can't reproduce such an error. Does the problem happen in a new application? You can try installing an older version from here. If the problem persists please send us your application to

Yes, it's a brand new application. All I did was create a new application, then I used entity framework core to map the Northwind database and the issue occurs.

Does installing an older version work? Or testing in a new empty application?

I tried 1.7.0 and it didn't fix it, but rolling all the way back to 1.6.0 did fix the issue.

Edit: I also re-updated to 1.8.0 and the application w/ Entity Framework with the imported Northwind db context still fails. However, creating a new application it works properly.

Please send us your application to as it seems the issue is somehow related to the app itself.

How would you prefer I send it? Your email server strips out zip files, and it generated quite a few files. (It's only 7MB zipped though)

You can use any cloud storage service - google drive, one drive, dropbox etc.

I got the project and reproduced the problem however the database context does not seem to be generated by Radzen Blazor Studio. How was it generated?

Tested with 1.6.0 and the same error occurs just a bit later - after picking the page template. We will see if we can support this database context and release a fix next week. For now you can delete the following code from it:

            entity.HasMany(d => d.CustomerTypes).WithMany(p => p.Customers)
                .UsingEntity<Dictionary<string, object>>(
                    r => r.HasOne<CustomerDemographic>().WithMany()
                    l => l.HasOne<Customer>().WithMany()
                    j =>
                        j.HasKey("CustomerId", "CustomerTypeId").IsClustered(false);

Thanks, I'll comment it out when creating new pages for now. I appreciate your rapid response on this issue.

Edit: Sorry I used the EntityFramework Core to generate the DB. Guess I need to learn how to have Radzen generate it. :smile:

Edit2: EF Core Database First - Learn How to Create Model From Database (
I used the command from there to generate the context from the Northwind Database

This appears to be working in today's release. Thank you!