SSRS Viewer ("Sorry, there's nothing at this address.")

I've been playing around with the SSRS Viewer for an hour or so and I just get "Sorry, there's nothing at this address." Does it work on client side?

<Radzen.Blazor.RadzenSSRSViewer ReportServer="http://swnhpr05/ReportServer/" ReportName="EH.UDS.ReportingServices/rtp_FMW" UseProxy="true">




</Radzen.Blazor.RadzenSSRSViewer>

Does it work if you set UseProxy to false?

Sadly not. I'd already tried that, and with it set to false it's just a blank. No report, no reported error, etc.

So, it's supposed to work client-side?

Do you mean webassembly? Yes, it should work in Blazor WebAssembly projects.

The reportviewer is nothing but an iframe which points to your SSRS server installation. In order to work the ReportServer should be properly set - you should be able to open the report in your browser from that url.

I can view the report in a browser with;

http://swnhpr05/ReportServer/Pages/ReportViewer.aspx?%2FEH.UDS.ReportingServices%2Frtp_FMW&rs:Command=Render

I've tried every combination of parameter into the compononent I can think of and, so far, no dice.

Here is how the reportviewer constructs the URL to the report:

It is quite similar to what you pasted.

If all the component is doing is throwing it into an iframe, I guess I could just skip the component and do that directly.

I see there's a component called BoldReports which may work better. I'll try that and see if it works better. I'm not sure I can spend any more hours on this one. I'm sure it's great, but it just doesn't work for me.

Well, if you check the code carefully you might notice that the component does a bit more when the proxy is in use.