Server Side 404 Error


I can’t seem to get my server code to work, the “http://app01//odata/TestManager/Customers” returns a 404 error.


Hi Jason,

Is this an SQL View or Table? We’ve just fixed similar error with views and tomorrow we will release official build.

Best Regards,

This was a table, the db has views too.

In this case this is different issue. I see there is a double slash in the url, can you try to request the same url without double slash?

I did not negate the code, Radzen did. How do I change it?

/odata/TestManager/Customers worked. How do I fix the project?

What version of Radzen you have used to deploy this app? Can you redeploy it using latest official?

The version is 1.28.0

Hi @jasoncraig,

Please send us the meta folder of your app together with .settings file to try to reproduce the problem locally.

Best Regards,

How do I send it? How do I remove the passwords?

I tried building a new project with version 1.28.1 and it still published it with the “//” in the URL (http://app01//odata/TestManagerProDataSource/Customers?$top=10&$skip=0&$count=true).

Hi @jasoncraig

Just zip the meta directory of your Radzen application and send it to No file in that directory contains any passwords.


Hi @jasoncraig,

Please verify if you have additional slash after the site name in deploy screen:

If this is the case you can remove it to fix the problem. We will do our best to improve it and we will release new official version before the end of the week.

Best Regards,