Radzen Installer broken

#1

Radzen 2.13.5 for Windows

Uninstalling and Reinstalling does not help :frowning:
image

0 Likes

#2

Just downloaded and installed on two different Windows 10 machines (64bit) and everything worked normally. What failed in your case? The installation itself or later when you try to run Radzen?

0 Likes

#3

The installation itself failed (uninstallation from control panel seemed to work fine), I now deleted the whole Radzen folder under Program Files, ran the installer again and thankfully it worked again.

1 Like

#4

I found out the problem was on my side, I deleted the node_modules folder in 'c:\Program Files\Radzen\resources'

How?
I wrote a little script which kills a node_modules folder in my project and replaces it with a symlink to 'c:\Program Files\Radzen\resources\node_modules'
Executing it twice resulted in the deletion of the symlink ... aaaand the symlink-target is gone too ...

Edit: For search reference i put a part of the screenshot here.
A JavaScript error occurred in the main process
Cannot find module 'electron-log'

0 Likes