msGraph infer issue

If I re infer msGraph on a working app I no longer have the ability to invoke getSitesListsItems()

I receive this message when I attempt to run the application

Cannot find operation with name "getSitesListsItems" in the "MSGraph" data source.

it appears that many items are removed from the MsGraphService.
originally the msGraphService consisted on 10040 lines, after I re infer it is down to 812 lines

I tried building a new app from scratch with MsGraph as the only data source and get the same result.

thanks for the help
michael

Hi @michael,

It seems that the meta data of the service was changed drastically. Is your app working normally runtime? Please use the old meta (restore it from your source control) until we find what's changed.

We were able to track what's changed and we've fixed the problem immediately. They've changed the namespace of the navigation properties type - fix will be released later today.

1 Like

Thanks again for the help. looks to be working now