Minimum Blazor example doesn't work

Hello,

I am working with VS 2019 and .Net 5.0 and created a default Blazor Webassembly application.

Then I installed your NuGet package Radzen.Blazor 3.0.6

My question: Even the most simple example with a progress bar doesn't work. What am I doing wrong?

I followed your instructions on this site:

My Index.html

<!DOCTYPE html>
<html>

<head>
    <meta charset="utf-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" />
    <title>BlazorApp1</title>
    <base href="/" />
    <link href="css/bootstrap/bootstrap.min.css" rel="stylesheet" />
    <link href="css/app.css" rel="stylesheet" />
    <link rel="stylesheet" href="_content/Radzen.Blazor/css/default-base.css">
    <!--<link rel="stylesheet" href="_content/Radzen.Blazor/css/default.css">-->
    <link href="BlazorApp1.styles.css" rel="stylesheet" />
</head>

<body>
    <div id="app">Loading...</div>

    <div id="blazor-error-ui">
        An unhandled error has occurred.
        <a href="" class="reload">Reload</a>
        <a class="dismiss">🗙</a>
    </div>
    <script src="_framework/blazor.webassembly.js"></script>
    <script src="_content/Radzen.Blazor/Radzen.Blazor.js"></script>
</body>

</html>

My Imports:

    @using System.Net.Http
    @using System.Net.Http.Json
    @using Microsoft.AspNetCore.Components.Forms
    @using Microsoft.AspNetCore.Components.Routing
    @using Microsoft.AspNetCore.Components.Web
    @using Microsoft.AspNetCore.Components.Web.Virtualization
    @using Microsoft.AspNetCore.Components.WebAssembly.Http
    @using Microsoft.JSInterop
    @using BlazorApp1
    @using BlazorApp1.Shared
    @using Radzen
    @using Radzen.Blazor


    public static async Task Main(string[] args)
        {
            var builder = WebAssemblyHostBuilder.CreateDefault(args);
            builder.RootComponents.Add<App>("#app");

            builder.Services.AddScoped(sp => new HttpClient { BaseAddress = new Uri(builder.HostEnvironment.BaseAddress) });

            builder.Services.AddScoped<DialogService>();
            builder.Services.AddScoped<NotificationService>();
            builder.Services.AddScoped<TooltipService>();
            builder.Services.AddScoped<ContextMenuService>();

            await builder.Build().RunAsync();
        }

* Then I changed the counter.razor page to this:

@using Radzen
@page "/counter"

<h1>Counter</h1>

<p>Current count: @currentCount</p>

<button class="btn btn-primary" @onclick="IncrementCount">Click me</button>

<br />

<h3>ProgressBar in determinate mode</h3>
<RadzenProgressBar @bind-Value="@value" Style="margin-bottom: 20px" />
<br />
<h3>ProgressBar in indeterminate mode</h3>
<RadzenProgressBar Value="100" ShowValue="false" Mode="ProgressBarMode.Indeterminate" Style="margin-bottom: 20px" />
<br />
<h3>ProgressBar in max value > 100</h3>
<RadzenProgressBar Value="156" Max="200" Style="margin-bottom: 20px" />

@code {

    double value = 55;

    private int currentCount = 0;

    private void IncrementCount()
    {
        currentCount++;
    }
}

It seems that the stylesheet does not load for some reason. Check your Browser's network tab for any failed http requests.