Is there anyone having problems with debugging in RBS? (SOLVED)

Hi everybody,

I have a problem with debugging in RBS. My debug features no longer work. After refreshing my operating system (Windows 10 Pro-22H2.19045.4529) I encountered this interesting problem.

When I run my projects the processes do not stop at the breakpoint. (I cleaned obj, bin folders) (The same projects work well in my testing virtual machine)

Can anyone make a suggestion?

PS.
The same projects work without any issues in my testing virtual machine.

We haven't made changes to debugging for quite some time. Could it be a Windows permission problem? Is there anything in the log file?

Hi @korchev,

I tried to find meaningful data to share with you. But for now there is nothing.

A new local admin user also did not resolve the result.

I've cleared the Event Viewer's logs (Windows Logs) and run the RBS but this gave me nothing.

I've created a simple project and added logging features. I've run the project on both my notebook and virtual machine.
I've put the breakpoints and run the project on both environments. I found something different from each other but the results were not very meaningful for me. I shared these logs with you. I'm sure It tells you more than me.

  • The virtual machine works well and the breakpoints are hit.
  • The notebook is not working well.

If these logs will not help us I'm not sure where must I search for more.

This is not a mission-critical issue, I can still debug my projects with the Code or the VS. I only wanted to report what I faced.

CombineLogFile.zip (1.3 KB)

Hi @korchev,

I found the reason.

In the task manager / Details tab, I've added the Command Line column and checked what is happening. I saw that the RBS run commands are not shown until the end. The path was different and longer than my other environment (that debug is running).

The reason:
If the Radzen Blazor Studio is tried to install with the "Only for me (UserName)" option the path's length probably would be long to read capability.
"C:\Users\UserName\AppData\Local\Programs\Radzen Blazor Studio" (for everyone C:\Program Files\Radzen Blazor Studio)
In this case, Radzen running commands can not be completed. The RBS is running but the debug option is affected.

After I used the shorter path everything was back as expected condition.